Retrieving DTCs with the ScanGauge

Discussion in 'Ford Hybrids' started by CarlD, Apr 19, 2009.

  1. CarlD

    CarlD Well-Known Member

    Well, another trip that didn't make it out of the driveway. Engine died, STOP SAFELY NOW, yadda, yadda, yadda. So I pop the hood expecting that F9 is blown again. Pull it and it is fine. Check ALL the fuses and relays and everything is kosher. Get back in and pull up the DTC xgauge and it is blank! Hmm, remember that if there is more than one DTC then the FEH will send them in a multi-frame message so the xgauge coding has to be changed. Have 3 PCM DTCs and EIGHT TCM DTCs! Yow. Check them out and most are "informational." So, remembering what the dealer did I check the fuel pressure.... ZERO. I code up an xgauge for Desired Fuel Pressure (0x1670 mode 0x22 PID) and it reads 39.8 psi. Turn the key to start and fuel pressure blips up to 5 or so psi before dropping back to 0. So fuel pump or fuel pump driver module not working. Lift up the left rear seat, open the panel, pull the connector to the fuel pump. Use OSC to turn the fuel pump on and read 11V at the fuel pump. So, FPDM is probably OK. Re-connect harness, command pump on again and nada. No noise, no fuel pressure. Gotta be a bad fuel pump. Woulda thought that the short on the FPDM input would have taken it out instead of the fuel pump, but so it goes.

    Order fuel pump online, lists for $165 but discounted price is $109. Place order, get call the next day saying the part has been superceded and the new list price is $465, $300 my price. Asks if I still want it, reply can you find one of the old $109 pumps? Guy laughs but says he'll try. Next day calls and says he found one, $115 delivered. Grab it and UPS shows up at the door 3 days later. Pull the old pump out, clean up O-ring area with q-tip and alcohol and install new pump. Tank cut out is razor sharp and get several cuts while putting in the new pump. Luckily had alcohol and q-tips handy. Button it up, turn the key to on and look at the SG. Desired FP 39.8, measured FP 52.1. Woo-hoo! Start the FEH and drive away happy.

    Did the short that blew F9 kill the fuel pump, or just a big coincidence? Parts guy said that the old fuel pumps on the first gen FEH did go out on occasion so I guess 94k miles and a short on the input of the FPDM might have combined to take it out. Next time I doubt any of the $109 pumps will still be around and the new, and I assume improved, $300 dollar pumps will be the only choice. Figure with a $465 list on the new pump and some labor it would be a $600 or more fix from the dealer.

    SO, if anybody gets a blank DTC xgauge, PM me and I'll walk you through the details. Blank DTC means a problem, no DTCs would show 0000.
    Last edited: Jun 22, 2010
  2. GaryG

    GaryG Well-Known Member

    Keep up the great work Carl! Did you read about the bad FEH battery Fans on GH? Your SGII DTCs are being overlooked by the dealer's equipment. I think it's caused by that battery wiring harness recall.

  3. 08hybridok

    08hybridok New Member

    I'll try to make a short story.

    12v batt - dead (7.7V) changed it, lost radio presets, kept sat ones. First step on brake the ABS lit up, hasn't since.

    So I've been watching the Vlt on SG, only 13.5 max when on, 12.2-12.5 off. Volt meter reads about 13.5-13.7 at the batt itself when on.

    So I reading this DTC message, I all ready had a BTC (SPC) code programmed, it read 2, on the 0745. Programmed the DTC reader part. on 0745 blank, on 0730 I got C155=u1155=lost communication with instrument cluster. all other modules were 0000.

    So you mention blank does not equal 0000, it sounds likt I may have a hidden code?

    Since I still have ext bumper to bumper warr. I'm not to concerened yet; but would still like to figure out what I can on my own, well I mean what you can find out for me!

    Thanks Carl for any more help you have.

  4. CarlD

    CarlD Well-Known Member

    Hi Bryan,

    Yes, blank means more than one DTC. Unfortunately, you will only be able to get the first one (and half of the second one!) If you just have a SG to talk to the car, you can read the DTCs one at time, erase it, then read the next. PITB, but the only way I can figure out how to do it so far.

    Unfortunately I'm travelling and won't be home until tomorrow. Seems like when I try to do stuff from memory I usually have a mistake or two thrown in. But, you might try changing the RXF to:

    RXF: 031015580000

    RXD: 3010

    to see if you get a display. This just looks for the first frame of a multi-frame response to the mode 0x18 DTC request..
    This will give the first DTC. If you want to then clear it, you will have to change the RXD to 4008 and see what it displays. This will be the status of the first DTC. You need to know that to clear it with a subsequent mode 0x14 request.
    Last edited: Jul 21, 2010
  5. 08hybridok

    08hybridok New Member

    Thanks for the help Carl. I tried the #'s you gave from memory:
    RXF: 031010000000

    RXD: 3010

    and they gave a code - A172 = B2172 = Inertia switch circuit open.
    Well, wouldn't that mean it won't start/run if either the HV or Fuel switches are off.

    I changed the RXD to 4010 (going by the note to retrieve code #2) and got 200a = p200a = nothing I could find.

    So then I cleared the codes. BTC went to 0, DTC was still blank (I think I reprogreammed it).

    So now I see the new code to try, put it it, and of course nothing because it's still cleared, after 2 short restarts. :(

    So for now I'll chalk it up to replacing the 12V batt, and I'll keep an eye on the 12V level, and BTC every now & then. I'll have the dealer check for codes when I go in for an oil change in ~5k miles, or if I get something on the message center.

    If it means anything the SG wad 'dead' when I left for work today, unplugged & replugged it and it came to life. (turned car off this time!)

    TAV was ~85 this afternnon in sun, 95+ temps, on retun trip, 2a 79F outside, it was ~91. Isn't that odd?

  6. CarlD

    CarlD Well-Known Member

    Unfortunately you can't get the entire second DTC with the SG. When you changed the RXD to 4010 you got the status of the first DTC (20, which means:Warning lamp was previously illuminated for this code, malfunction not currently detected, code not yet erased) and the first half of the second DTC, 0A which means DTC P0A?? probably P0A0A.
    Based on the status byte of 20, the FEH is just waiting a certain amount of time without detecting the fault again before it clears the code on its own.

    When I replaced my 12V battery I had a DTC of P1000 from the PCM for several weeks. That just meant that the OBD drive cycle hadn't been completed. You could try going to CMNDS, enter 1800FF00 and hit SEND to see if you have the same.

    I don't know how the 08 does battery cooling but on my 2005 the A/C for the battery runs anytime the Tav is 85F or more and the ICE is on. I know the 2008 changed things with regards to A/C, though.
    Last edited: Jul 25, 2010
  7. lone ranger

    lone ranger Well-Known Member

    Would entries for the RXF, RXD, and MTH remain the same despite the change in the first 4 digets of the TXD?
  8. CarlD

    CarlD Well-Known Member

    Yup, everything else the same. The RXF does not check which module responded, but it can only be the one that the TXD was talking to.

    You can also try 07E0 for the PCM and 07E1 for the TCM. There are DTCs from these modules that won't show up when the SCAN button is used. There is also a module at 07E2 which is purportedly the OBD addy for the TBCM, but I've never seen anything out of it.

  9. rkantor

    rkantor New Member

    Hi guys! I know this post is old, but my wife's 08 Escape FEH had the red triangle twice the other day. I bought an SG II and was running some of the diagnostics. No OBD codes or module codes until I used 07E0, then it comes up with 1. I am also unable to get current traction battery temp to read, but I can get the high temp (max) to read. Any ideas?
  10. rkantor

    rkantor New Member

    Also, a little confused 0x18 requests? Still very new to using SG.
  11. CarlD

    CarlD Well-Known Member

    Odd that the PCM is reporting a code but no other any rate, go to the CMNDS menus and enter 1800FF00 and hit SEND. This should tell you what DTC the PCM is reporting, coded as per the post at the beginning of this thread.

    The battery air temp xgauge doesn't work for 08's for some reason. The Tav is a better indicator of the HV battery temp anyway, and it works on the 08.
  12. rkantor

    rkantor New Member

    Thanks! I typed the command and I retrieved 2 different answers after a couple of inquiries. First was 58010A3EFF000000, second was 58011A0DFF000000. I was trying to decode this, but this don't look like anything I have seen perusing the forum, unless these are 2 DTC's a piece? Hmm.
  13. CarlD

    CarlD Well-Known Member

    Hmm, probably one from the PCM and one from the TCM. First response is 0A3E and the second is 1A0D. These can be decoded as:

    0A3E --> 0 for P0A3E --> Generator Motor Inverter over temp

    1A0D --> 1 for P1A0D --> Generator Disabled

    These would almost certainly point to the Motor Electronics cooling pump. A very common problem that I thought was fixed by 2008. It could be just a bad ground, but probably the pump itself. The new pump lists from Ford for $282 but can be found online for about $160. Labor should not be more than an hour but dealerships may charge more. For 2 hours labor and retail on the pump it will be in the $600 range.
    Last edited: Oct 13, 2011
  14. rkantor

    rkantor New Member

    Great! I see how you got the code by dropping the front and back digits...... I was monitoring the temp and noticed it 80's, over 100 on startup (makes sense, no circulation). It looks like the larger old style pump. I verified operation by listening, but I'll check connections and prepare for replacement... It looks like an easy swap out. I wish I remembered (and knew) more about the interpretation of these codes. If there any more stickies or threads with this info, I'll be sure to read them. Thanks!
  15. CarlD

    CarlD Well-Known Member

    The wikipedia on OBD-II PIDs is pretty good, although there are some inaccuracies.

    Just be aware when trying to understand the CMNDS response that the Scangauge strips off the address and the PCI (number of data bytes) byte from the response. Your first response from the ecu actually looked something like:

    before it was trimmed for display on the sg.

    Also when constructing xgauges the PCI byte is determined automatically by the sg. This was done so people wouldn't have to count the number of data bytes themselves.
    Last edited: Oct 13, 2011
  16. CarlD

    CarlD Well-Known Member

    Well, I get to keep adding to this thread, unfortunately. Once again, the FEH didn't make it out of the driveway. It had been sitting for two weeks and started right up and then shut down 5 seconds later with STOP SAFELY NOW, SERVICE SOON and various other messages. Just for fun I put the insrument cluster into test mode and it showed nOne for dtc despite the fact that the FEH was dead. Also, SCAN on the sg showed no DTCs but the DTC xgauge showed P0A1F in both the PCM and TBCM. WSM says TBCM has internal errors so new HV battery. However, I found a TSB that describes the problem exactly and it just says to flash the TBCM to the latest rev:


    I'm sure the dealer will want to run a diagnostic first; I have yet to be able to stop them from doing this.
    Last edited: Nov 14, 2011
  17. CarlD

    CarlD Well-Known Member

    Forgot to update what the resolution of my last problem was: 12V battery failed two months past the 36 month free replacement period. $50 bucks to get another Motorcraft battery with another 36 month warranty. Third battery in 5+ years, counting the one that was in it when I got it. Typical for Phoenix though; batteries just don't like dry heat. But after walking around the Montreal Botanical Gardens yesterday in 95F and humid I won't be complaining about 110F and 4% humidity.....OK, probably still will complain until I move to San Diego.
  18. CarlD

    CarlD Well-Known Member

    Well, another Stop Safely Now and now my FEH is out of the hybrid warranty. This one is a puzzler as I have DTCs from the PCM of P1A14 (Transmission disabled, an informational DTC)and P1A10 (HV Battery disabled, another informational DTC) and a DTC from the TCM of P0A0A (HV Interlock.) There are NO DTCs from the HV Battery module. The HVINTLCK PID from the TCM indicates that the interlock circuit is closed, which the PC/ED manual directs me from section HJ to Z, which is intermittent. Wiggling and re-setting the harness never changes the HVINTLCK PID to open. No way I'm going to spray water on any of the connectors as the manual says. Probably time to hunt down loose grounds or maybe try re-programming the various modules. I guess......


    Got the VCM-2 and IDS and was surprised to find no way to re-flash the TCM. I updated the PCM and BCM to the latest calibration but the TCM calibration, dated November 2004, was the latest available. But that did nothing to solve the no-start HV interlock problem. I did notice, though, that the PC/ED manual procedure for HV Interlock has changed somewhat from 2005 to 2009. In the 2005 PC/ED manual, if the TCM Interlock PID indicated closed, one is directed to section HJ15 and from there to Z, which is the general intermittent diagnosis. In the 2009 PC/ED, one is directed to HJ8 and the IFS switches are indicated as the problem. I took my jack out and wiggled the wiring and switch and lo and behold the engine started, ran for a couple of seconds and started running very rough and then stopped with the SSN. I repeated this a few times so I think the IFS switch may be funny. The F9 fuse has never blown like it did before, but I think the several times it blew before may have damaged the IFS switch. Either that or my new fuel pump is bad after less than 5k miles. Or, perhaps, the fuel pump driver module. Interesting that the HV Interlock diagnosis procedure has changed, though. Ford must have seen these issues over the years.


    It was the front IFS switch; the 09 diagnosis manual got it right! One thing I did notice that since I updated the PCM and BCM is that the FEH is more reluctant to turn the engine off. Before, when coasting in D the engine would drop out at 30MPH. Now it doesn't shut off until about 22MPH. Also, the max charge values are reading higher, 29.2kW as compared to before when I never saw more than 27.2kW.

    Lesson learned is that for the HV Interlock DTC, first check the fuel pressure! The default fuel pressure doesn't display on the ScanGauge, but one can be programmed using xgauges. The xgauge changed for 09 and up, though, with the switch to ISO 14229 protocol from the SAE J2190.
    Last edited: Jul 7, 2013
  19. CarlD

    CarlD Well-Known Member

    A little clarification on clearing the codes. If you want to clear a specific code, you must change the TXD to 074514abcd where abcd is the coded DTC. For example, if you had the blend door DTC of 9239 the TXD to clear it would be 0745149239. You can also clear all codes by prefix by changing the TXD to 074514abcd where abcd is:

    0000 for P DTCs
    4000 for C DTCs
    8000 for B DTCs

    C000 may be for U DTCs but I'm not sure.

    In the original post the FF00 clears ALL info, including freeze-frame data for all DTCs.

    Again, the 0745 is for the Battery computer. For other computers this changes as described above.

    Hope nobody ever needs this info.......:cool:

    Also note that this is for J2190 modules, which is all HCAN modules for 2005-08. Starting in 2009 some of the modules are ISO14229 and this won't work on those.
    Last edited: Jun 18, 2014

  20. I'm having the same exact problem that Jmistche had but I get additional codes I can't read. When we spoke earlier there was a 12V battery code but I replaced the battery and that's gone. Now it's P0A27 which is the battery harness I suppose but there are other codes. Sometimes 2 total, sometimes three.

    Briefly, with the Key on, running or not, the car detects a fault after 15 seconds to 2 minutes, beeps once, kills the IC engine, disables the EV, opens the blend door, turns on the battery fans and displays "Stop Safely Now". In 10-15 minutes the fans stop, the blend door closes and the car will start.

    I can't seem to get the specific codes to clear. The FF00 bomb clears everything but 0000 and abcd seem to have no effect. They do not decrease the codes reported by SPC.

    In the post above you said that abcd should be the DTC code, but earlier and elsewhere you said that clearing codes used the status data. Should I use abcdef where ef is the status code - 0745140A2720 ? I'm afraid to enter things blindly.

    TXD: . . . . . .RXF: . . . . . . . RXD: . Math: . . . . . NAME: Response
    0745220200 046205020600 3008 000100010000 SPC 2

    07451800FF00 045810000000 2810 000100010000 DTC <blank>

    07451800FF00 031015580000 3010 000100010000 DT1 0A27 P0A27

    07451800FF00 031015580000 4010 000100010000 DT2 200A another P0A code!!??

    trying to see past the first code...
    0745140A27 045410000000 4010 000100010000 C#1 <blank> (SPC still 2)

    0745140000 045410000000 4010 000100010000 C#2 <blank> (SPC still 2)

    074514FF00 045410000000 4010 000100010000 C#3 cleared them both (SPC 0)

    (These also didn't work when I tried to clear the 12V battery code)

    That FF00 bomb is dangerous!. Programmed in as an X-gauge it shows up in the Gauge rotation and can clear codes as you go past.

    Thanks for all your help Carl.
    Last edited: Jun 20, 2014

Share This Page