Sluggish Google and Bing Maps

Discussion in 'Off-Topic' started by Jay, Sep 10, 2017.

  1. Jay

    Jay Well-Known Member

    Anybody else besides me notice this? I use Google Maps quite often and over the last several days response has been extremely slow. I know it's not my connection because other sites pop in OK and speed tests show ~95Mb up and down with normal latencies. I just tried Bing maps and the lag is crazy slow--completely unusable.

    What's going on?
     
    BillLin likes this.
  2. BillLin

    BillLin MASS: 2018 Bolt EV and 2017 Prime

    Sorry, I have not noticed any lag.
     
    Jay likes this.
  3. EdwinTheMagnificent

    EdwinTheMagnificent Legend In His Mind

    I have noticed the same problem with Google Maps. I thought it was just my computer.
     
    Jay and BillLin like this.
  4. PaleMelanesian

    PaleMelanesian Beat the System Staff Member

    Hurricane traffic maybe?
     
    Jay and BillLin like this.
  5. BillLin

    BillLin MASS: 2018 Bolt EV and 2017 Prime

    Sure, I was thinking that, too... Or spikes in video streaming when you just want a simple map update. A lot of web sites load tons of graphics and video, whether you want it or not, and it is too much to ask to shut off graphics for a little less bandwidth use. The infrastructure just needs to adapt and scale up. But this thought about increasing bandwidth demand does not account for Jay's mention of other sites not being similarly impacted.

    One other thought... all those cars that are now using Android Auto and live Google maps. :D
     
    Jay likes this.
  6. jcp123

    jcp123 Caliente!

    I haven't really noticed, but I've had fairly spotty signal more often than usual of late...so I chalked it up to that.

    I wouldn't discount the hurricane traffic though. Everywhere I've been since Irma turned serious has been flooded with Florida license plates. Including one Lexus SUV in a pretty nasty accident in Maine...but anyway, I'm sure they're using the heck out of all kinds of mapping services.
     
    Jay and BillLin like this.
  7. Jay

    Jay Well-Known Member

    I have a linux box and I thought maybe an upgrade disabled my graphics accelerator but I find nothing amiss. I'm going to go with the heavy usage theory.
     
    BillLin likes this.

Share This Page