Help! New (to me) 2003 Civic Hybrid, IMA light after replacing Battery, inverter, etc

Discussion in 'Honda Hybrids' started by HCHinOhio, May 22, 2014.

  1. HCHinOhio

    HCHinOhio New Member

    Help!

    I've been lurking here over the last year. I purchased an 03' Civic hybrid last year with a bad battery, purchased an 8 AH bumblebee battery, and have been relatively trouble free over the last year.

    Until...I swiped a pole with that Civic. Both Drivers doors are destroyed as well as the B pillar/rocker.

    Lucky for me, found another 2003 Civic Hybrid with 90k. The previous owners could not figure the IMA issue out and made me a great deal on it. When i purchased it yesterday, the car would start when jumped, but after a short amount of time the car would stop running. I swapped in my known good IMA battery (Bumblebee Refurb), 12v Battery (YellowTop Optima), the inverter and the computer on top of the inverter. (All known good from other Hybrid)

    If i reset the electronics by pulling the battery. It will start (using starter), the gauges shows charge/assist activity, but the IMA gauge always shows 0. After a short drive the IMA comes on, and all charge/assist activity stops. Also, the 12v battery light will come on at idle after the IMA re-triggers. It goes away when revved up. I've also checked the fuses under the hood and under dash.

    I'll update this post with code(s) within a couple hours. I have a complete parts car to use and would love to figure this out.

    Please help! :confused: I want to :stickshift:
     
  2. mmrmnhrm

    mmrmnhrm Well-Known Member

    Re: Help! New (to me) 2003 Civic Hybrid, IMA light after replacing Battery, inverter,

    I wouldn't be too surprised to find that there's a mismatch between firmware revisions somewhere. Sadly, only a dealer would be able to diagnose/correct that sort of issue.
     
  3. retepsnikrep

    retepsnikrep Member

    Re: Help! New (to me) 2003 Civic Hybrid, IMA light after replacing Battery, inverter,

    When you get the codes we will be able to help.

    You need the IMA subcodes which you can flash out if you don't have a proper obd reader.
     
  4. HCHinOhio

    HCHinOhio New Member

    Re: Help! New (to me) 2003 Civic Hybrid, IMA light after replacing Battery, inverter,

    Thanks for the replies guys, I've temporarily been driving by switching the battery "off" and unplugging 1 of the 4 harness plug-ins for the ima computer, I unplugged the one furthest from the ima battery.

    I'll have my hands on a Bluetooth obd2 reader tomorrow , I plan on clearing the codes, disconnecting the 12v, plugging in the harness I unplugged, switching my ima switch to "on", reconnecting the 12v, and seeing which code(s) trigger first

    Thanks for the help! Look for an update later today
     

Share This Page