FAS mod on my Insight

Discussion in 'General' started by highwater, Oct 28, 2006.

  1. highwater

    highwater Well-Known Member

    After a PM from another forum member here at CleanMPG, asking about getting some pics of my FAS mod installation, I decided to write this so others could benefit also.

    SOME HISTORY:

    A fellow forum member, Calpod, started this mod by killing the ignition at the under-dash fuse box, and then progressed to breaking the 3 fuel injectors signals with a multi-pole relay. He later initiated the clutch switch mod as an extension of his previous work. Another member of the Insight community, JoeMultihuller, was in pursuit of a one wire cut that would give us factory AS, but as far as I know, the one wire has yet to be found.

    The objective of this mod; to allow an on demand ICE off condition, at any vehicle speed, while maintaining all the safeties and restart functions that are inherent in the factory AS. It will do just that. All this without having to do the key switch one/two maneuver, which we named BFAS (BruteForceAutoStop). This mod is now also referred to as safeFAS, since the factory restart safeties have been duplicated.

    The ICE restart safeties that I mentioned are:

    (1.)restart upon brake vacuum depletion, which in my experience is ~4 pumps of the brake pedal,
    (2.)restart when the accelerator pedal is touched, and
    (3.)restart when the transmission is shifted into any gear.
    (4.)restart when SOC is depleted past a certain point(following paragraph).

    In my experience, this mod, as I have done it, in my Insight, as described below, will NOT work when my battery iSOC is below 3 bars from the bottom. Works fine at 3 bars up, but let the iSOC drop down to 2 bars and the ICE will restart, when the momentary FAS switch is released. If ICE-off is desired at this stage, I must either do the BFAS or hold the FAS switch closed. I do not dwell down around this iSOC, but I have been down there and this is how I observed the operation of my system at that point. I am seeing that all Insight IMA’s are not created equal, with respect to SOC properties.

    We decided to call it (ForcedAutoStall) because that is basically what is going on, an ICE stall. When activated, one will see the battery, oil, and brake indicators come on, then when the vehicle speed drops below the appropriate mph the factory green AS indicator will come on.

    While searching through the ETM (Electrical Troubleshooting Manual), as well as the SM (Service Manual) to do this mod on my Insight, I saw that the clutch and neutral signals were in the same ECM connector as the 3 injector signals, and presented the possibility that we could use those 2 signals, with a second relay, to control the function of this mod more eloquently. Mike Dabrowski said, “yes we certainly can”, and gave us the schematic, for a single-switch activation, two-relay, clutch hold set-up. Thus we called the second relay, the clutch hold relay, as now there is no need for a second switch to control the clutch signal (for FAS purposes), or for the operator to hold the clutch in manually. The schematic is available on Mike’s webpage. http://www.99mpg.com/Data/downloads/relateddocuments/highwaterfas.pdf

    BUILDING THE RELAYS:

    I basically followed the schematic, with the exceptions of slightly different components (just because I had them on hand and they would work); and on the clutch hold relay, Mike potted one of his indicator led’s inside the epoxy, and I think also the resistor for the external led, was potted internally; whereas I, for some unknown reason at the time, just brought out both of those pins as 12v out, and put my led’s and resistors externally. These 12v out signals, turned out to be advantageous, which I will get to shortly.

    Mike and I had similar problems when potting these relays in epoxy. When potting my relays for the first time, the epoxy ran past the pins and got inside the relays, welding everything together:mad: . Nice mess, started over. I used bases for the relays this time. Remembering correctly, I think Mikes problem was from the heat generated by the epoxy setting up, that warped the relays causing the contacts to spread.

    [​IMG]
    Building the injector cut relay. These are the 3 injector wires passing through the injector cut relay.

    [​IMG]
    Before deciding to use a 6 pin connector, I left plenty of wire, as I wasn’t for sure where to put the relays after all was said and done.​

    The plug–in bases had tighter pins, but I coated the bottom side with silicone to keep the epoxy from running past the pins and welding the bases to the relays, and also put silicone between the two bases and taped them together until dry to keep the epoxy from running down between the relays.

    I had several small project boxes on hand that I thought about using to surface mount the relay bases in, which would also house the other components, but this method of potting the relays with the other components encased, is compact and durable.

    [​IMG]
    Aluminum tape makes the dam for the epoxy.​

    In the above picture you can see the silicone that I smeared around the base of the pins to keep the epoxy from running down in the cavities. I measured out a length of aluminum tape to go around the relay bases and cut back the backing paper, so just enough sticky would be left to stick to the bases themselves. I left the backing paper on, where it would be in contact with the epoxy, hoping it would turn loose easier once the epoxy was dry. It worked pretty well, but I did have to scrap and file a little on the epoxy to clean up some of the backing paper. I squared up the epoxy anyway, with a file, once it was dry.

    [​IMG]
    Rolling the tape around the relay bases.

    [​IMG]
    FAS relays in hardened epoxy, cleaned up, squared up, with pigtails.​

    I used .062 dia. Molex connectors, one 6 pin for the 3 injector wires and a 9 pin for everything else, creating two pigtails coming from the epoxy. The injector plug is a 6 pin for which I made a bypass plug, that would allow the mod to be “unplugged” for trouble shooting or repair...etc.

    The 9 pin connector is for:
    1. Ground
    2. +12v power
    3. clutch signal
    4. neutral signal
    5. MIMA switch connection
    6. Secondary switch connection
    7. 12v signal out for LED indication. (put my resistors external)
    8. Duplicate of #7
    9. (Empty, but it does help in orientation when putting this thing together)

    Don’t need a bypass for the 9 pin plug, as the clutch and neutral signals are tap connections, and as you can see in the pictures below, the 9 pin contacts are protected by the configuration of the plug housing, when disconnected. Yes, that was intentional. On the other hand the injector signals are hijacked through the injector cut relay, and since they pass through said relay in the default NC (normally closed (failsafe)) position, the bypass plug makes the connections, should the relay be removed. I tossed the bypass plug in the glove box along with 2 spare relays.

    MAKING THE UNDER DASH CONNECTIONS:

    I used one of the 3 aux male spade terminals at the top of the under dash fuse box for +12v, (hot when key-on) and grounded at the place where the MIMA board is grounded, inside the shift console.(closer to the relays so less wire to run).

    For the MIMA users:

    By loosening the shift console, and unwrapping the MIMA harness where the extra wires are, I was able to get to the AR2 connection, the brown wire in the picture, to use that function as an FAS activation. I did have to add some length to it (the brown wire) for my needs, as I put the relays laying on the top left corner of the ECM housing cover.

    For the non-MIMA folks:

    The AR2 on the MIMA board is an auxiliary relay that provides a path to ground when the central joystick position is pressed straight down. Simply put, the MIMA joystick can be used as the momentary FAS activation switch. I do have a second switch which I will get to shortly, but let me get past the relay install first.

    [​IMG]
    Wiring the MIMA AR2 connection.​

    I didn’t take any pics of the actual ECM wiring connections. If you’ve been there you know this is not the most convenient place to take a pic. It is tough enough to get the solder connections done up under the dash, while laying half in and half out of the passengers door, and well … you get that picture. (pun intended)

    [​IMG]
    ECM side of the FAS wiring.

    [​IMG]
    ECM wiring rerouted up and around.​

    As you can see in the last picture, only the ECM connections have been plugged into the connectors at this point. 3 coming and 3 going to the injector signals in the 6 pin plug, and the clutch and neutral signals in the 9 pin plug. A closer look at the brown wire, which in my case is the clutch signal, reveals there are 2 brown wires. I didn’t have the same gage wire in brown that I used for the neutral signal (yellow), so I used two strands to make up for the smaller gage. I didn’t want to risk restricting, or perhaps overheating (not likely as these are milliamp signals) using just one strand, so I doubled up. Satisfied myself anyway.

    All the other connections to the 9 pin plug were done at this point. Switches, +12v, GND, etc.

    [​IMG]
    All connections are now made to both plugs.​

    In this picture you can see the other wires coming in from the left to the 9 pin plug. I fed them through a piece of heat-shrink before crimping the ends on and pushing them into the backside of the plug. Tidies things up a bit and adds a measure of protection. The injector bypass plug is also shown. It is simply another male 6 pin plug, like the one coming from the relays, with jumpers wires inserted.

    A word of advise here: The injector wires must remain segregated. 1 to 1, 2 to 2, 3 to 3, always. Don’t get them crossed when making all the connections or making these plugs.

    [​IMG]
    FAS relays hiding behind the carpet.​

    All done with the passengers carpet back in place. The relays are barely visible behind the carpet, left center of picture. Just on top of the grey cable you can see the white coil wrapper inside the clear plastic relay housing. That red thing is the cover on my OBD cable.

    OK, there you have the _FAS clutch hold relay install_ minus your choice of indication and momentary switch. I will cover my FAS indicator in another write up because it (the FAS on indicator) is tied in with some other stuff. I don’t see that you absolutely need an indicator, as when you do an FAS with what has been presented up till now, your dash will light up just like it does with the key-switch (Brute Force) maneuver. The battery, brake and oil lights will come on, then check for zero rpm’s and……well duh! :Banane44: I’m in FAS.:Banane44: But I do like my indicators.

    NOW FOR THE MOMENTARY SWITCH:

    Here’s mine:

    [​IMG]
    Stuff growing on the shifter:eek: .​

    The little black box forward of the shifter knob is my MIMA joystick mount. Also notice the zipper sewn in the shift boot, and the Ram laptop mount peaking around the corner. The zipper allows the wires to be routed down into the console, also the MIMA joystick box and FAS switch housing to pass through when removing the console. More on these in other threads coming up shortly (zipper story is here). I’ll put links in here when I get them posted. The joystick is one of my FAS switches, activated by pressing straight down when the joystick is in the central relaxed position. The black housing, with the red buttons that is mounted below the MIMA attachment, contains the other FAS switch, and another, yet to be determined momentary switch function:Banane36: . The forward red button, that would be intuitive for the thumb to operate, is the FAS switch. The lower portion of the shifter knob itself, had to be relieved of some of it’s OD, to allow all this stiff to fit.

    THE LATEST REVISION:

    The latest addition to the FAS mod is the DC/DC enable function.

    When in FAS, the DC/DC is not engaged until the factory green AS indicator comes on. Those that have, or are performing the key-switch (BFAS) maneuver, have probably noticed the head lights coming back to a brighter state after the AS indicator comes on. That is if you drive at night. Half of my commute is headlights on. During the testing of my Insight at night, for the Insight Marathon, I experienced lots of strange electrical activity as the 12v battery became depleted, and was not given enough charge time during the short pulses. I emailed Mike, and ask for help in getting the DC to stay hooked up during the ICE off time. He promptly replied with; “monitor this,” “watch that,” and finally, “looks like we need to try opening this wire”. It actually turned out to be rather easy to keep the DC alive during FAS.

    On the DC/DC connector, in the IMA cabinet, the pin 6 is the DVINH signal. This signal was low when the DC/DC was engaged (ICE on, or when in AS), and high when the key was in position II with ICE off (such as before ICE start or in BFAS). So logically, if we wanted the DC to remain on line during FAS, the signal needed to be opened (low) for the duration of the FAS.

    Enter another relay, and the advantage previously mentioned about not potting any resistance in the bases of the FAS relays. I took one of the 12v out signals from the clutch hold relay, ran it to the IMA cabinet via a spare wire in the MIMA harness (read, very easy since the MIMA cable is already in position) to power a little SPDT 12v relay. I ran the pin 6 signal through the relay in the NC position (fail safe).

    When the FAS switch is activated, the clutch hold relay passes 12v, activating the DC enable relay which opens the pin 6 signal. This condition is held, by the clutch hold relay, until any restart command takes over.

    [​IMG]
    DC/DC enable relay harness.​

    This is all there is to the DC/DC enable relay wiring harness. You will probably need the above pic to find the harness in the pic below. The following pic is the DC/DC relay installed. You can see the single pin Molex connector, connected to the spare wire in the MIMA cable which brings in the 12v from up front (near that bar coded label in the center of the picture). The pin 6 signal is ran through the relay via a small 2 pin pre-wired connector, which is soldered in line very close to the DC/DC IMA connector. This little 2 pin connector is normally used for battery pack connections to circuit boards and such. I used this connector, so I could make a bypass plug for the DC/DC relay, like I did with the fuel cut relays up front. I like bypass plugs, can you tell? If you ever need to trouble shoot this stuff, a lot of possibilities can be eliminated by unplugging these mods. The ground wire was attached nearby, although I did have to rotate the ground wire around a little bit to get the Styrofoam back in place, and also had to move the harness out of the way, from what you see in the following picture.

    [​IMG]
    DC/DC enable relay installed.

    [​IMG]
    DC/DC relay bypass plug.​

    The bypass plug is seen next to the red alligator clip lead from the multi-meter. This picture was taken before the wiring harness was installed. It (the bypass plug) has about 1 inch of wire looped inside some heat-shrink to form a pull handle. Tossed it in the glove box with the other bypass plugs and spare relays. Strange collection building up in the glove box:D . (Maybe I’ll do a thread on that subject.)

    Well, that’s the FAS mod as I have done it.

    With the addition of the DC/DC enabling, the battery and brake light no longer illuminate on the gage cluster. The only light that comes on now is the oil light. We know that there is no oil pressure during AS, so why do we need to see it during FAS. I’m working on that. It appears to be another one wire thing. I’ll try it out and update later. I have to get back into the shift console to do the test, but hey, I have a zipper. :cool:

    Randall
     
    Last edited: Nov 19, 2006
  2. HAFNHAF

    HAFNHAF Well-Known Member

    AWESOME POST!!! copied and saved for later use. i, too want a FAS mod. i do the "kill the fuel pump at the fuse block" method. its been working fine for over a year, but its not the most "elegant" solution. i already have 2 relays in bases mounted on an aluminum carrier. maybe i should add a third? the loss of dc/dc during FAS bugs me. no real problem, but again, its not the elegant approach.

    thanx for the great post/pix!
     
  3. Mike Dabrowski 2000

    Mike Dabrowski 2000 Well-Known Member

    Nice job Randall.
    I was going to play with expanding my website discription for FAS, to give Calpod the credit due for being the first, as well as to clarify how to do it, when I finally open the rear to do the DC/DC stay alive, but you have already captured it so well that I will link to this thread instead.
    Cool stuff.
    I should order some Molex connectors, so I can keep it clean.
    ;)
     
  4. xcel

    xcel PZEV, there's nothing like it :) Staff Member

    Hi Randall:

    ___Excellent documentation of the FAS switch and Inverter Alive mod(s)! Thanks for posting and great pics too!

    ___Good Luck

    ___Wayne
     
  5. highwater

    highwater Well-Known Member

    Thanks guys,
    About those connetors Mike, there are smaller physical sizes available, as well as other brands, but I have the Molex brand on hand in two sizes, that being the .062 and the .093, with the dedicated crimpers, so I just used what I had. They could optimally be smaller perhaps.

    One thing I was hoping to point out (so that others like myself, who might be learning as we go, could benifit), is that when doing something like this, make it so there is only one way to plug it in. In the picture of the finished relays, notice there is one male plug and one female. Even if both were the same pin count, there is only one way to plug it in. Also, if things are unplugged, which configuration of connector will be the safest? Can the exposed pins be shorted? Does there need to be some measure of protection taken, such as a cap or a dead plug? Or a bypass plug?

    I'm certainly not speaking to you here Mike, just wanted to get that point across for other budding modders, that might follow later, or on their other projects.

    Randall
     
  6. hobbit

    hobbit He who posts articles

    What was the original motivation for shutting down the DC/DC in FAS
    anyways? Other cars that leave it on and just slowly draw down
    the HV battery don't seem to consider it any risk, since the ICE
    can always be restarted to charge if needed. Why make the power rail
    to the ECUs always be wailing up and down between 12V and 14V
    unnecessarily?
    .
    _H*
     
  7. highwater

    highwater Well-Known Member

    I'm reading a couple of questions in your post there hobbit, me thinks anyway....


    When traveling at night and doing a lot of hardcore P&G in the Insight, there is not enough pulse time compared to glide time, to keep the 12v system up to the needed levels to run through the night. The 12v eventually runs down to the point of creating problems. Been there...done that...not pretty.


    We don't want to restart the ICE in the Insight, just to charge up the HV pack. (poor FE) We want it to charge only on the Pulse, and that being a force charge, which on the insight is a little stiffer than a normal back gorund charge, and it will keep up the HV pack to needed SOC, for the sweet IMA restarts, and also provide enough SOC to keep the 12v in good shape, since the DC/DC is now engaged.

    By my cheapee DPM the voltage does not vary that much, only about 250 mV, from around 14.1 in FAS, to 13.85, with the ICE running.

    There are other things that may come along on the Insight, (see Mike), that we would want the dc/dc to be engaged for.

    Randall
     
    Last edited: Nov 10, 2006
  8. MattyG

    MattyG New Member

    This link is dead, but I found this document.

    I don't fully understand transistors and diodes (took Circuits I but not Circuits II), but if this circuit energizes and holds energized the relay on the right, when does it de-energize that relay?

    I want to build the FAS, but I want to cut corners without removing the auto restart. What if I just hardwire the clutch switch to the depressed position? Any other way to avoid learning how to breadboard? ;-)

    Thanks
    Matt
     

Share This Page