Another person's mileage logs mixed in with my own?

Discussion in 'Website news & discussions' started by ericbecky, May 19, 2008.

  1. ericbecky

    ericbecky Member

    I just checked my logs today and see someone else mileage is mixed in with my logs.

    I usually have tanks in the 50's, 60's and 70's.
    But I see that there are tanks added to my car's profile that are int he 30s and 40s?

    How could that happen, and more importantly, can it be fixed.

    I don't know where they came from, and I was going to start erasing them all. But since this may be someone else's data, I figured I better report the problem here first. Actually, now that I try it, I can't seem to edit the other entries? I did not try to delete them yet.

    Help!!
     
  2. kwj

    kwj I hypermiled this

    That's happened to mine also. I see that it has not changed my averages in any way. Shucks, that other driver had tanks in the 70s too.
     
  3. ericbecky

    ericbecky Member

  4. Right Lane Cruiser

    Right Lane Cruiser Penguin of Notagascar

    Eric, I see the issue. It might take me a while to resolve -- I need to make code updates so this can't happen anymore.

    kwj and Eric, you both have the same vehicle name. Let me play with it a little and see if I can't unravel the issue.

    The quick fix is for KWJ to change the name of his vehicle back to something unique instead of "Red"
     
  5. ericbecky

    ericbecky Member

    Yeah, I just saw that it was kwj! Too funny!

    Kwj.. can ya' make the change Sean is suggesting?
     
  6. Right Lane Cruiser

    Right Lane Cruiser Penguin of Notagascar

    If it helps put your mind at ease at all, the tanks aren't really combined. Each entry is indexed by both username and vehicle name. The display code called when you click on a vehicle only searched the DB by vehicle name, though. You can't edit each other's tanks because each one is checked to see if the owner is the one viewing it.
     
  7. ericbecky

    ericbecky Member

    Yeah, I was pretty sure we had some other safeguard in place.
    Given the traffic on the site today, don't worry about spending a lot of time on this. :)

    I wish I would've seen that other post first, then I could've just worked it out with kwj behind the scenes. Oh well, hopefully this will alert someone else if they run into the same issue.

    Thanks Sean!
     
  8. Right Lane Cruiser

    Right Lane Cruiser Penguin of Notagascar

    If you guys don't mind leaving it the way it is for a while I can work on it when I get home -- I have to get the DB queries correct.
     
  9. ericbecky

    ericbecky Member

    Sure. I'll leave it. No harm done at this point.
     
  10. Right Lane Cruiser

    Right Lane Cruiser Penguin of Notagascar

    I'm closer now. I got your tanks unmixed but now people with multiple cars have info that is mixed together.
     
  11. Right Lane Cruiser

    Right Lane Cruiser Penguin of Notagascar

    Okay. I've finally got the issue licked. Please double check and let me know if either of you see anything amiss.
     
  12. ericbecky

    ericbecky Member

    Sean,
    You rock!
    Things look A-OK.
     
  13. Right Lane Cruiser

    Right Lane Cruiser Penguin of Notagascar

    Glad to help. :D
     
  14. kwj

    kwj I hypermiled this

    I just changed to Red Toy. Took me awhile to remember how to do that. My tank records looked fine to me. Again, sorry to have caused you all the trouble.
     
  15. Right Lane Cruiser

    Right Lane Cruiser Penguin of Notagascar

    No problem, KWJ. I actually had the issue resolved so you can put it back to just "Red" if you like :)

    It has happened at least 3 other times in the last couple of months so I needed to fix that bug anyway. ;)
     

Share This Page